PDA

View Full Version : new whine and slow backhoe operation


brady-yzf
01-17-2010, 02:43 PM
My Kubota L35 with the BT 900 backhoe attachment just started making a whine when I extend the lower arm. I've also lost power on this range and it takes a lot longer to extend the hoe as well. Is something stuck in the valve? I'm assuming that I need to draing the fluid, disassemble and clean the valves, and hope nothing is really broken. Any advice would be very helpful!

Doc
01-17-2010, 04:04 PM
Welcome to Net Tractor Talk Brady!!!! :thumb: :D

Sorry to hear about the problem. First thing I'd do is check the fluid level. It sounds like it might be low. I've heard of them making noise when the fluid was low.

brady-yzf
01-17-2010, 05:12 PM
yep, checked that first, she's full. Im thinking that there is something obstructing the opening in the valve body. I think I'll start by cleaning it out and see if that helps

Jeep
01-18-2010, 01:02 AM
change your Hyd filter first before you take the valve apart sounds like it's starven? for fulid. Jeep

brady-yzf
01-18-2010, 11:59 AM
Too late, I already dissassembled the valve body, but I'll certainly change the filter and the fluid upon reassembly. I'll let you know what the issue was, hopefully it's one of the two.

brady-yzf
02-03-2010, 11:13 AM
Well, it's not the fluid nor filter-both are fresh. I also dissassembled and inspected the loader and backhoe valve bodies. I also dissassembled the quick-connects to make sure they had no obstructions.
Perhaps I'm not adequately describing the symptom: It's not really a loud, high-pitched whine, but more of a slightly audible noise when the machine is in neutral hydraulic position. It's a noise that sounds like the pump is under load. I'm hypothesizing that the problem could be with a stuck relief valve. I think this because the noise goes away while an attachment (either loader or backhoe) is moving. Do relief valves commonly get stuck?

THe other thing is that the noise is not that bad, but I've never noticed it before and it just doesn't sound like I think a smooth running machine ought to. THat said, I don't want to fix something that isn't broken.

Thanks,
Brady

brady-yzf
02-03-2010, 11:15 AM
Oh, I forgot to mention that I replaced the seals in the dipperstick and boom cylinders, that fixed the slow backhoe extension. One problem fixed!

brady-yzf
02-12-2010, 05:08 PM
Ok, it's fixed. THought I'd let anyone interested know what it was: stuck relief valve.

Doc
02-12-2010, 06:14 PM
Thanks for the follow up on this Brady. I'm sure it will come in handy to some of us on down the road. :thumb: :tiphat:
Glad you got yours fixed. Did you have to replace the relief valve or simply un stick it?