Net Tractor Talk
       

Go Back   Net Tractor Talk > Brand Specific Forums > Massey Ferguson Forum

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-30-2017, 04:10 AM
Hugh Rea Hugh Rea is offline
Junior Member
 
Join Date: Dec 2017
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Hugh Rea is on a distinguished road
Default Massey 7475 Starting Issues

Hi everyone, I have a 2008 MF 7475 (Perkins engine) and one of the plastic fuel line clips wore out and due to delivery times it was replaced with a rubber fuel line.

However now it doesn't want to start, turns over but doesn't want to start, cannot get any error codes on the Dot display but there is a CI.70 or C1.70 displays on the other screen which I have not noticed before.

Any help appreciated, thank you
Reply With Quote
  #2  
Old 12-30-2017, 10:13 AM
thcri's Avatar
thcri thcri is offline
Senior Member
 
Join Date: Apr 2007
Location: On the border
Posts: 261
Thanks: 104
Thanked 182 Times in 101 Posts
thcri is on a distinguished road
Default

Quote:
Originally Posted by Hugh Rea View Post
Hi everyone, I have a 2008 MF 7475 (Perkins engine) and one of the plastic fuel line clips wore out and due to delivery times it was replaced with a rubber fuel line.

However now it doesn't want to start, turns over but doesn't want to start, cannot get any error codes on the Dot display but there is a CI.70 or C1.70 displays on the other screen which I have not noticed before.

Any help appreciated, thank you
Who replaced the line? Has it ever run with the new line? Was the injectors bled?
__________________
It's been really a long day and I don't feel like I did anything
Reply With Quote
  #3  
Old 12-30-2017, 01:41 PM
Hugh Rea Hugh Rea is offline
Junior Member
 
Join Date: Dec 2017
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Hugh Rea is on a distinguished road
Default

I fitted the line. It was bled to the pump and started pretty much straight away. It has done 3 days work and doesn't seem to be short of power or miss when running it is just when it is stopped it doesn't want to start again.
Reply With Quote
  #4  
Old 12-31-2017, 01:01 AM
thcri's Avatar
thcri thcri is offline
Senior Member
 
Join Date: Apr 2007
Location: On the border
Posts: 261
Thanks: 104
Thanked 182 Times in 101 Posts
thcri is on a distinguished road
Default

Quote:
Originally Posted by Hugh Rea View Post
I fitted the line. It was bled to the pump and started pretty much straight away. It has done 3 days work and doesn't seem to be short of power or miss when running it is just when it is stopped it doesn't want to start again.

Is it possible that you could have a small air pocket in one of the lines going up to the injectors or even in the pump? Other than that I am out of ideas.
__________________
It's been really a long day and I don't feel like I did anything
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





All times are GMT -5. The time now is 01:03 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2002 - 2018, www.DotHQ.com