Net Tractor Talk

       

Go Back   Net Tractor Talk > Other Equipment Forums > Kubota RTV Owners Group Forum

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 04-07-2012, 10:56 AM
micpib1 micpib1 is offline
Junior Member
 
Join Date: Jun 2011
Location: Northern California
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
micpib1 is on a distinguished road
Default RTV500 Servo Adjustment

I have 45 hours on my RTV500 and will be doing my 50 hour service soon, if I don’t scrap it first. I know this whole thing sounds a little redneck, but, on a hill, my RTV500 will not “downshift”, as it runs out of power, I just continue to release the throttle-servo controller until I am down to a fast walking speed. When the unit was new, I did seem to get just a little “downshift”, but now, nothing. I have lots of power at “walking speed”, I just cannot achieve higher RPMs unless I am going downhill. So yesterday, I removed my bench seat, attached a ¼ inch drive socked with a long extension to the end of the Servo Adjustment Screw and removed my bench seat so I could attempt a Servo adjustment while on the move. I made several runs at the same hill, first while holding wide open throttle, adjusting the screw both in and out with no “downshift”. My next run, I released the throttle to approx. ¾, adjusting while on the move, still no “downshift” and again, the same run at ½ throttle, still no change. Is there any hope for this unit or is it time to move on to something else? JH
Reply With Quote
  #2  
Old 04-08-2012, 03:32 AM
rj's barn rj's barn is offline
Member
 
Join Date: Aug 2008
Location: Oklahoma
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
rj's barn is on a distinguished road
Default

Start with the basics. Make sure you don't have a clogged air or fuel filter. The machine might be screaming for the 50 hour service. If it's a hydro tranny the filter might be full of "wear-in" shavings and have restricted flow. Try fresh fuel. That kind of stuff. Beyond that I'd pick my dealers brain.
Reply With Quote
  #3  
Old 04-08-2012, 06:36 AM
DIXIEDOG DIXIEDOG is offline
Senior Member
 
Join Date: Jun 2010
Location: Maine
Posts: 211
Thanks: 0
Thanked 2 Times in 2 Posts
DIXIEDOG is on a distinguished road
Default

You want to adjust your servo screw out...you can continue to move out a turn or so at a time until you feel it "downshifting" correctly. If you go too far your machine will not move and you know you'll need to go back in.


Another huge difference in power can be made by doing the RPM adjustment, a tech over on the &&&&&&&&&&&& forum suggested bumping the wide open RPM to 4000 plus or minus 100 a couple years back.....the difference in power is amazing. To perform that adjustment you need an inductive pickup tach to do so accurately.


After I adjusted my servo and rpm my RTV 500 had a ton more power, I'm able to take off spinning tires in 4WD on gravel now which I never had that type of acceleration before....when climbing hills I just keep the throttle down and the rpms automatically come up like the should. It's a much more pleasurable machine to drive now, the only time I've run out of power was in deep gooey mud but that's not surprising given the hp rating and weight of the unit.
Reply With Quote
  #4  
Old 04-08-2012, 08:10 AM
micpib1 micpib1 is offline
Junior Member
 
Join Date: Jun 2011
Location: Northern California
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
micpib1 is on a distinguished road
Default

Thanks for the ideas, I will report back. JH
Reply With Quote
  #5  
Old 04-15-2012, 02:18 AM
micpib1 micpib1 is offline
Junior Member
 
Join Date: Jun 2011
Location: Northern California
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
micpib1 is on a distinguished road
Default

Today, I did my 50 hour service, both transmission filters looked like new on the inside and the fluid looked just like the new Super UDT that I poured in. The engine oil was a little dirty, but I was impressed on just how clean it actually was, the oil filter did have just a little staining on it, but nothing alarming. I took it out for a test drive after running it for a few minutes and then topping off the fluids, still no difference on the same hill that I had tested and reported on earlier on this thread. I will try adjusting the servo “out” a little more tomorrow, but I am beginning to think the RTV is not for me.
I have been a Kubota fan for most of my working life, I am currently running a L39 Backhoe/Loader with the GST Transmission and a G1600 AWS Mower with the Hydro Transmission, had a 245 and a 295 in the past. As I said, I have been a Kubota fan for a long time, but I am very disappointed. JH
Reply With Quote
  #6  
Old 04-16-2012, 04:25 AM
General Lee General Lee is offline
Junior Member
 
Join Date: Jan 2011
Location: Maryland
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
General Lee is on a distinguished road
Default

Dixedog is right on how to adjust everything. I also have a 500 w/ 45 hours on it. I've been thinking about adjusting mine but to worried that I'll mess something up. I've read where several had made the adjustments and it made huge improvements.

Fluids, tune up, etc is not the problem. The servo and rpms are not correctly set from the factory, it is what it is. I have a love hate relationship with my 500. It's a good machine for working and hauling but I just wish it had a little more punch.
__________________
Kubota L4400
Kubota RTV500
Reply With Quote
  #7  
Old 04-19-2012, 10:12 PM
micpib1 micpib1 is offline
Junior Member
 
Join Date: Jun 2011
Location: Northern California
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
micpib1 is on a distinguished road
Default

Quote:
Originally Posted by General Lee View Post
Dixedog is right on how to adjust everything. I also have a 500 w/ 45 hours on it. I've been thinking about adjusting mine but to worried that I'll mess something up. I've read where several had made the adjustments and it made huge improvements.

Fluids, tune up, etc is not the problem. The servo and rpms are not correctly set from the factory, it is what it is. I have a love hate relationship with my 500. It's a good machine for working and hauling but I just wish it had a little more punch.
Today, I backed my servo adjustment screw out a total of three and one half a turns, one half a turn at a time. It has made a noticeable difference in my uphill power, downhill power and speed has remained the same (ha-ha). I tested after every half turn on the same hill each time, I can now actually get the RPMs to increase while going uphill, and like everyone else, I still need to back off of the throttle just a little to allow it to "shift". JH
Reply With Quote
  #8  
Old 04-20-2012, 06:29 AM
vpexp vpexp is offline
Junior Member
 
Join Date: Apr 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
vpexp is on a distinguished road
Default

You may want to change the fuel filter if you did not when did your service. I had the same problem with my 1100. I had the dealer do the 50 hour service and after driving it a few hours had the same power issue up hills, etc. Finally determined that they had not changed the fuel filter when they serviced it. After replacing the filter all is well.
Reply With Quote
  #9  
Old 04-20-2012, 06:46 AM
bczoom bczoom is offline
Senior Member

 
Join Date: Apr 2006
Posts: 4,785
Thanks: 33
Thanked 95 Times in 86 Posts
bczoom is just really nicebczoom is just really nicebczoom is just really nicebczoom is just really nice
Default

Does the 500 have the aux pump in the tranny like the bigger models?
E.g. When I'm going up something big/steep and the machine bogs down, I let off the "gas pedal" to about 1/2 way which engages the secondary pump. At that point, the speed goes down but the power and RPM's go way up and we're back in action.
Reply With Quote
  #10  
Old 04-20-2012, 08:48 AM
Bucks_071 Bucks_071 is offline
Junior Member
 
Join Date: Apr 2012
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Bucks_071 is on a distinguished road
Default

Bczoom,
Yep, the 500 is the same, with the second pump.
Reply With Quote
  #11  
Old 04-20-2012, 10:05 AM
bczoom bczoom is offline
Senior Member

 
Join Date: Apr 2006
Posts: 4,785
Thanks: 33
Thanked 95 Times in 86 Posts
bczoom is just really nicebczoom is just really nicebczoom is just really nicebczoom is just really nice
Default

JH/micpib - Are you letting off the pedal to get the power gain?
Reply With Quote
  #12  
Old 04-20-2012, 10:51 AM
micpib1 micpib1 is offline
Junior Member
 
Join Date: Jun 2011
Location: Northern California
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
micpib1 is on a distinguished road
Default

Yes, I am backing off on the throttle a little and then I can manipulate the throttle for a little more RPMs and power. Without the servo adjustment, I would just continue letting up on the throttle and just running out of power until I was at a brisk walking speed, it was like trying to pull my loaded toyhauler up a steep hill in overdrive. The 500 always had lots of low end power; I was just down to a crawling speed or low range going up even a mild hill. JH
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 10:17 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©2002 - 2012, www.DotHQ.com