Net Tractor Talk
       

Go Back   Net Tractor Talk > Brand Specific Forums > Kubota RTV Owners Group Forum

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-07-2019, 12:40 PM
Cfitz Cfitz is offline
Junior Member
 
Join Date: Mar 2019
Posts: 21
Thanks: 5
Thanked 8 Times in 7 Posts
Cfitz is on a distinguished road
Default Rtv 900 slow travel

My 2010 rtv 900 will only go 10Ė12 mph on flat ground. Charge pressure is over 100 psi, high pressure is at about 3700 psi, brakes are not suck all tires will roll free when jacked up, servo lever is moving all the way, it takes off strong at first but the engine revs and you do not continue to gain speed, will do 30 mph on jack stands.
Does anyone have anything else I can try?
Reply With Quote
  #2  
Old 03-07-2019, 12:51 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 1,502
Thanks: 315
Thanked 901 Times in 545 Posts
aurthuritis is on a distinguished road
Default

i suspect internal wear. how many hours on the machine?
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
  #3  
Old 03-07-2019, 02:12 PM
Cfitz Cfitz is offline
Junior Member
 
Join Date: Mar 2019
Posts: 21
Thanks: 5
Thanked 8 Times in 7 Posts
Cfitz is on a distinguished road
Default

1300hrs I pulled the rear of the hst unit off and the brass all seemed to be in good shape I canít really feel anything with my finger nail
Reply With Quote
  #4  
Old 03-07-2019, 03:46 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 1,502
Thanks: 315
Thanked 901 Times in 545 Posts
aurthuritis is on a distinguished road
Default

could you see radial lines in the plates? could you see spots that looked like tarnish? also i don't think you can see the part that seals against the pump without disassembly. i have seen a 900 that had the pin on the servopiston worn almost in half and that wouldn't allow the swash plate to be fully engaged.
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
  #5  
Old 03-07-2019, 03:49 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 1,502
Thanks: 315
Thanked 901 Times in 545 Posts
aurthuritis is on a distinguished road
Default

http://www.nettractortalk.com/forums...ad.php?t=17179

maybe this will help
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
  #6  
Old 03-07-2019, 04:07 PM
Cfitz Cfitz is offline
Junior Member
 
Join Date: Mar 2019
Posts: 21
Thanks: 5
Thanked 8 Times in 7 Posts
Cfitz is on a distinguished road
Default

I don’t recall any radial lines or tarnish. I had the assist pump off and the block that seals against the main pump and drive pump. The linkage going from the servo to the servo piston has a small amount of slop in it. Could that make that big of a difference?
Reply With Quote
  #7  
Old 03-07-2019, 04:11 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 1,502
Thanks: 315
Thanked 901 Times in 545 Posts
aurthuritis is on a distinguished road
Default

Quote:
Originally Posted by Cfitz View Post
I donít recall any radial lines or tarnish. I had the assist pump off and the block that seals against the main pump and drive pump. The linkage going from the servo to the servo piston has a small amount of slop in it. Could that make that big of a difference?
possibly. review the thread i link in the above post. it is long but has very good step by step photos. the main problem turned out to be slop in the servo piston control button and swash plate. any slop will result in less travel of the swash resulting in slow speed. not sure that is your problem but worth a look.
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
  #8  
Old 03-07-2019, 04:17 PM
Cfitz Cfitz is offline
Junior Member
 
Join Date: Mar 2019
Posts: 21
Thanks: 5
Thanked 8 Times in 7 Posts
Cfitz is on a distinguished road
Default

I will check it out and compare it to mine and let you know what I find
Reply With Quote
The Following User Says Thank You to Cfitz For This Useful Post:
aurthuritis (03-07-2019)
  #9  
Old 03-07-2019, 04:54 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 1,502
Thanks: 315
Thanked 901 Times in 545 Posts
aurthuritis is on a distinguished road
Default

just rambling a little. most people think that messing with the servo adjustment screw will make these go faster. the only thing that screw does is center the servo piston travel. also to much pressure on the HPRV will cause the swash plate pin and button to wear prematurely from all of the extra force on the components.
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
  #10  
Old 03-07-2019, 09:32 PM
Cfitz Cfitz is offline
Junior Member
 
Join Date: Mar 2019
Posts: 21
Thanks: 5
Thanked 8 Times in 7 Posts
Cfitz is on a distinguished road
Default

The swash pin and bock are very tight and have no visible wear. I will pist pictures of the plates soon.
Reply With Quote
  #11  
Old 03-07-2019, 10:06 PM
Cfitz Cfitz is offline
Junior Member
 
Join Date: Mar 2019
Posts: 21
Thanks: 5
Thanked 8 Times in 7 Posts
Cfitz is on a distinguished road
Default




Sent from my iPhone using Tapatalk
Reply With Quote
The Following User Says Thank You to Cfitz For This Useful Post:
aurthuritis (03-10-2019)
  #12  
Old 03-07-2019, 10:18 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 1,502
Thanks: 315
Thanked 901 Times in 545 Posts
aurthuritis is on a distinguished road
Default

are you going to put new plates in it while you are there? have you seen where the servo actuates the swash?
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
  #13  
Old 03-07-2019, 10:28 PM
Cfitz Cfitz is offline
Junior Member
 
Join Date: Mar 2019
Posts: 21
Thanks: 5
Thanked 8 Times in 7 Posts
Cfitz is on a distinguished road
Default

Yes I took the servo piston out and checked the pin and block on it they are perfect. I will put plates in it if you think they look worn. They are defiantly not warped and I still donít feel anything with my fingernail.


Sent from my iPhone using Tapatalk
Reply With Quote
  #14  
Old 03-07-2019, 10:33 PM
Cfitz Cfitz is offline
Junior Member
 
Join Date: Mar 2019
Posts: 21
Thanks: 5
Thanked 8 Times in 7 Posts
Cfitz is on a distinguished road
Default




Sent from my iPhone using Tapatalk
Reply With Quote
The Following User Says Thank You to Cfitz For This Useful Post:
aurthuritis (03-10-2019)
  #15  
Old 03-07-2019, 10:35 PM
Cfitz Cfitz is offline
Junior Member
 
Join Date: Mar 2019
Posts: 21
Thanks: 5
Thanked 8 Times in 7 Posts
Cfitz is on a distinguished road
Default




Sent from my iPhone using Tapatalk
Reply With Quote
The Following User Says Thank You to Cfitz For This Useful Post:
aurthuritis (03-10-2019)
  #16  
Old 03-07-2019, 10:45 PM
Cfitz Cfitz is offline
Junior Member
 
Join Date: Mar 2019
Posts: 21
Thanks: 5
Thanked 8 Times in 7 Posts
Cfitz is on a distinguished road
Default




Sent from my iPhone using Tapatalk
Reply With Quote
The Following User Says Thank You to Cfitz For This Useful Post:
aurthuritis (03-10-2019)
  #17  
Old 03-08-2019, 06:55 AM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 1,502
Thanks: 315
Thanked 901 Times in 545 Posts
aurthuritis is on a distinguished road
Default

well dog gonnit. it would be nice to be able to find an absolute failure. after all the trouble to get to where you are i think i would replace the plates,they aren't that expensive are they?
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
  #18  
Old 03-08-2019, 08:19 AM
Cfitz Cfitz is offline
Junior Member
 
Join Date: Mar 2019
Posts: 21
Thanks: 5
Thanked 8 Times in 7 Posts
Cfitz is on a distinguished road
Default

I havenít priced them yet I was really hoping to find something that looked broken.


Sent from my iPhone using Tapatalk
Reply With Quote
  #19  
Old 03-08-2019, 10:11 AM
Lee1935 Lee1935 is offline
Senior Member
 
Join Date: Aug 2017
Location: Northport Wa/ property in BC with a elevation of 1490 ft to 2500 feet, with Mts behind that hit 6000
Posts: 204
Thanks: 47
Thanked 100 Times in 76 Posts
Lee1935 is on a distinguished road
Default

I hate to assume but you did check the simple things?
There's a recent post on this forum about collapsed hydraulic oil intake hoses ☺
Reply With Quote
  #20  
Old 03-08-2019, 10:14 AM
Cfitz Cfitz is offline
Junior Member
 
Join Date: Mar 2019
Posts: 21
Thanks: 5
Thanked 8 Times in 7 Posts
Cfitz is on a distinguished road
Default

Wouldnít that affect my charge pressure? Are they to two grey ones on the back?


Sent from my iPhone using Tapatalk
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





All times are GMT -5. The time now is 11:51 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright ©2002 - 2018, www.DotHQ.com