Net Tractor Talk
       

Go Back   Net Tractor Talk > Brand Specific Forums > Kioti Forum

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-04-2017, 05:20 PM
danielbelisle danielbelisle is offline
Junior Member
 
Join Date: Jan 2017
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
danielbelisle is on a distinguished road
Default CK30HST - No hydrolics in forward or reverse

I started my tractor today, let it warm up for an hour or so at -15 degrees Celsius. I have no forward or reverse drive nor do I have hydrolic power to lift bucket and 3-point hitch. Also, no steering.

No hydrolic power whatsoever.

I will try replacing the filters.

What else could be the problem?

Thanks
Dan
Reply With Quote
  #2  
Old 01-04-2017, 06:01 PM
Doc's Avatar
Doc Doc is offline
Chief Bottle Washer / Admin

 
Join Date: Apr 2007
Location: Ohio USA
Posts: 5,682
Thanks: 1,417
Thanked 357 Times in 222 Posts
Doc is on a distinguished road
Default

Sounds like the fluid is not moving, you might have water in the mix and it's frozen. If that is the case all will be working once again once it warms up.
__________________
Scott me up Beamy!

Other Fun Forums:
Forums Forums .com +++ Net Boat Talk Forums +++ Net Cooking Talk Forums +++
Reply With Quote
  #3  
Old 01-04-2017, 06:13 PM
danielbelisle danielbelisle is offline
Junior Member
 
Join Date: Jan 2017
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
danielbelisle is on a distinguished road
Default

I agree with you though we have had much colder temperatures last month and the tractor moved just fine. However, I will wrap the tractor up and try to warm it up. Will let you know how I make out.
Thanks for your quick response and help.
Danielbelisle
Reply With Quote
  #4  
Old 01-04-2017, 06:48 PM
Doc's Avatar
Doc Doc is offline
Chief Bottle Washer / Admin

 
Join Date: Apr 2007
Location: Ohio USA
Posts: 5,682
Thanks: 1,417
Thanked 357 Times in 222 Posts
Doc is on a distinguished road
Default

Good luck. I've seen cold weather really impact operations on some of my equipment ..hopefully that's all it is with yours.
__________________
Scott me up Beamy!

Other Fun Forums:
Forums Forums .com +++ Net Boat Talk Forums +++ Net Cooking Talk Forums +++
Reply With Quote
  #5  
Old 01-12-2017, 09:40 AM
danielbelisle danielbelisle is offline
Junior Member
 
Join Date: Jan 2017
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
danielbelisle is on a distinguished road
Default fixed problem

Hey Doc fixed problem..Sure enough my HST oil was contaminated with water. Oil was creamy white. Had to wrap entire tractor in insulated tarps and used a Mr. Heater 50000 btu heater for 4 hours under tractor. It started after taht. Brought it in a warm garage changed oil and filter and ready to go. The temp here in northern Canada is -20F. Thanks
Reply With Quote
  #6  
Old 01-12-2017, 03:07 PM
Doc's Avatar
Doc Doc is offline
Chief Bottle Washer / Admin

 
Join Date: Apr 2007
Location: Ohio USA
Posts: 5,682
Thanks: 1,417
Thanked 357 Times in 222 Posts
Doc is on a distinguished road
Default

Brrrr now that is ka ka ka COLD. Wow.
Glad that's all it was. Congrats on getting er going again. Way to go. Just 70 days until spring. Hope that helps a little. Take care and stay warm!!!!!
__________________
Scott me up Beamy!

Other Fun Forums:
Forums Forums .com +++ Net Boat Talk Forums +++ Net Cooking Talk Forums +++
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





All times are GMT -5. The time now is 11:59 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2002 - 2018, www.DotHQ.com