Net Tractor Talk
       

Go Back   Net Tractor Talk > Brand Specific Forums > Kubota RTV Owners Group Forum

Reply
 
Thread Tools Search this Thread Display Modes
  #21  
Old 12-02-2019, 10:34 AM
dtreid dtreid is offline
Member
 
Join Date: Nov 2018
Posts: 58
Thanks: 0
Thanked 59 Times in 27 Posts
dtreid is on a distinguished road
Default

The motor valve block it $1k so I hope it's not that. It looked like new so I doubt it.
Reply With Quote
The Following 2 Users Say Thank You to dtreid For This Useful Post:
beagle hunter (03-01-2020), Doc  (12-04-2019)
  #22  
Old 12-03-2019, 02:10 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 2,006
Thanks: 390
Thanked 1,627 Times in 982 Posts
aurthuritis is on a distinguished road
Default

just out of curiosity,is there a screen in the intake from the tank??? any collapsed hoses or air leaks?
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
The Following 2 Users Say Thank You to aurthuritis For This Useful Post:
beagle hunter (03-01-2020), Doc  (12-04-2019)
  #23  
Old 12-03-2019, 10:02 PM
dtreid dtreid is offline
Member
 
Join Date: Nov 2018
Posts: 58
Thanks: 0
Thanked 59 Times in 27 Posts
dtreid is on a distinguished road
Default

There is a screen in there. I haven't had a look at it.
Reply With Quote
The Following 2 Users Say Thank You to dtreid For This Useful Post:
beagle hunter (03-01-2020), Doc  (12-04-2019)
  #24  
Old 12-03-2019, 10:30 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 2,006
Thanks: 390
Thanked 1,627 Times in 982 Posts
aurthuritis is on a distinguished road
Default

might be a good idea????
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
The Following 2 Users Say Thank You to aurthuritis For This Useful Post:
beagle hunter (03-01-2020), Doc  (12-04-2019)
  #25  
Old 12-04-2019, 10:15 AM
bordercollie's Avatar
bordercollie bordercollie is offline
Senior Member
 
Join Date: Apr 2007
Location: central Mississippi
Posts: 4,585
Thanks: 2,026
Thanked 1,850 Times in 992 Posts
bordercollie is on a distinguished road
Default

Those screens cause a lot of grief for people owning all different colors of equipment . I'd sure check it. Good luck, collie
Reply With Quote
The Following User Says Thank You to bordercollie For This Useful Post:
beagle hunter (03-01-2020)
  #26  
Old 12-09-2019, 11:03 PM
dtreid dtreid is offline
Member
 
Join Date: Nov 2018
Posts: 58
Thanks: 0
Thanked 59 Times in 27 Posts
dtreid is on a distinguished road
Default

I pulled the tank screen out. It had some gunk on it, but was certainly not very restricted. There was however, some metal pieces in the bottom of the tank...

Pulled the tranny apart again.

Can't see anything amiss. Pulled all of the valves out of the valve body to check them. Nothing unusual.

I removed the cover to servo piston assembly. There were a couple of little metal chunks in there.

When I move the speed control lever on the servo regulator assembly, should the servo piston move?

With things taken apart, if I push on the pump swash plate, I can't move it as the servo piston doesn't move. Is this normal?
Reply With Quote
The Following User Says Thank You to dtreid For This Useful Post:
beagle hunter (03-01-2020)
  #27  
Old 12-10-2019, 04:55 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 2,006
Thanks: 390
Thanked 1,627 Times in 982 Posts
aurthuritis is on a distinguished road
Default

the servo piston uses hydraulic pressure to move the swash plate. have you disassembled the servo piston assy completely? there was once that had extreme wear on the pin that connects the piston to the swash. but i don't think this would account for low pressure.
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
The Following User Says Thank You to aurthuritis For This Useful Post:
beagle hunter (03-01-2020)
  #28  
Old 12-10-2019, 08:16 PM
dtreid dtreid is offline
Member
 
Join Date: Nov 2018
Posts: 58
Thanks: 0
Thanked 59 Times in 27 Posts
dtreid is on a distinguished road
Default

If the servo was stuck so it couldn't move the pump swash plate much could this cause the low pressure issue?
Reply With Quote
The Following User Says Thank You to dtreid For This Useful Post:
beagle hunter (03-01-2020)
  #29  
Old 12-10-2019, 08:33 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 2,006
Thanks: 390
Thanked 1,627 Times in 982 Posts
aurthuritis is on a distinguished road
Default

to be honest i don't know but i don't think a stuck servo would cause low pressure.
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
The Following User Says Thank You to aurthuritis For This Useful Post:
beagle hunter (03-01-2020)
  #30  
Old 12-10-2019, 08:45 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 2,006
Thanks: 390
Thanked 1,627 Times in 982 Posts
aurthuritis is on a distinguished road
Default

is there another unloader valve other than the poppet on the rear???
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
The Following User Says Thank You to aurthuritis For This Useful Post:
beagle hunter (03-01-2020)
  #31  
Old 12-14-2019, 02:05 PM
dtreid dtreid is offline
Member
 
Join Date: Nov 2018
Posts: 58
Thanks: 0
Thanked 59 Times in 27 Posts
dtreid is on a distinguished road
Default

Got it fixed! The motor was toast so definately needed a new one, but the low pressure problem after it was replaced was a stuck anti-cavitation valve. I had to clean it up a bit so that it would move freely. I think that it was not able to fully close so that it could only build 200psi pressure. After studying the schematic I could see that it would dump the pressure back into the case if it wasn't fully seated.
I now have a working tranny!
Reply With Quote
The Following 6 Users Say Thank You to dtreid For This Useful Post:
aurthuritis (12-14-2019), bczoom  (12-15-2019), beagle hunter (03-01-2020), bordercollie (12-14-2019), shinnery (12-14-2019), v10rick (12-15-2019)
  #32  
Old 12-14-2019, 05:10 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 2,006
Thanks: 390
Thanked 1,627 Times in 982 Posts
aurthuritis is on a distinguished road
Default

YEAH!!!! Thanks for posting.
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
The Following User Says Thank You to aurthuritis For This Useful Post:
beagle hunter (03-01-2020)
  #33  
Old 12-14-2019, 07:03 PM
bordercollie's Avatar
bordercollie bordercollie is offline
Senior Member
 
Join Date: Apr 2007
Location: central Mississippi
Posts: 4,585
Thanks: 2,026
Thanked 1,850 Times in 992 Posts
bordercollie is on a distinguished road
Default

That's so helpful to know . Other owners will benefit from this thread. Thanks ! bordercollie
Reply With Quote
The Following User Says Thank You to bordercollie For This Useful Post:
beagle hunter (03-01-2020)
  #34  
Old 02-19-2020, 10:38 PM
Big David Big David is offline
Junior Member
 
Join Date: Feb 2020
Posts: 3
Thanks: 3
Thanked 3 Times in 3 Posts
Big David is on a distinguished road
Default

I am having the same problem.My valve body was in bad shape .Replace it.Put it back together and it still didn’t work.How did you determine that main drive valve body was bad.
Reply With Quote
The Following User Says Thank You to Big David For This Useful Post:
beagle hunter (03-01-2020)
  #35  
Old 02-20-2020, 10:24 AM
dtreid dtreid is offline
Member
 
Join Date: Nov 2018
Posts: 58
Thanks: 0
Thanked 59 Times in 27 Posts
dtreid is on a distinguished road
Default

If there are any scratches or other damage on the pistons or cylinder that they fit in to, it will require a new valve body.
If there is any scratches or damage to the plates that the valve bodies rest on they must be replaced as well. Tolerances are very tight, so any damage will cause pressure leaks.
Reply With Quote
The Following 3 Users Say Thank You to dtreid For This Useful Post:
aurthuritis (03-01-2020), beagle hunter (03-01-2020), Big David (02-22-2020)
  #36  
Old 03-01-2020, 09:55 AM
Big David Big David is offline
Junior Member
 
Join Date: Feb 2020
Posts: 3
Thanks: 3
Thanked 3 Times in 3 Posts
Big David is on a distinguished road
Default

Put it all back together.Reinstalled unit i cleaned all of the check valves .i have 120 psi at the charge pump but no other psi at any of the ports.when I moved the lever on the servo the charge psi never changed .When I increased the rpm the charge psi changed to 115 so I think the charge relief valve is working .I followed your post but I can’t find anything wrong with the motor cylinder block but I can’t find any specs.on Clearances for the pistons my small block was a lot more damaged than your picture showed.How much was the motor block a plate .
Reply With Quote
The Following User Says Thank You to Big David For This Useful Post:
beagle hunter (03-01-2020)
  #37  
Old 03-01-2020, 12:21 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 2,006
Thanks: 390
Thanked 1,627 Times in 982 Posts
aurthuritis is on a distinguished road
Default

if the brass colored plates have any scratches or warp throw them away and buy new. it the pistons or motor block show any ANY wear or scratches get a new one.
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
The Following 2 Users Say Thank You to aurthuritis For This Useful Post:
beagle hunter (03-01-2020), Big David (03-01-2020)
  #38  
Old 03-01-2020, 03:17 PM
Big David Big David is offline
Junior Member
 
Join Date: Feb 2020
Posts: 3
Thanks: 3
Thanked 3 Times in 3 Posts
Big David is on a distinguished road
Default

Should the charge psi change when the servo lever is moved.
Reply With Quote
The Following User Says Thank You to Big David For This Useful Post:
beagle hunter (03-01-2020)
  #39  
Old 03-01-2020, 09:18 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 2,006
Thanks: 390
Thanked 1,627 Times in 982 Posts
aurthuritis is on a distinguished road
Default

Quote:
Originally Posted by Big David View Post
Should the charge psi change when the servo lever is moved.
i could fluctuate a little but no it should maintain charge pressure
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
The Following 2 Users Say Thank You to aurthuritis For This Useful Post:
beagle hunter (03-02-2020), Big David (03-01-2020)
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





All times are GMT -5. The time now is 02:13 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright 2002 - 2020, www.DotHQ.com