Net Tractor Talk
       

Go Back   Net Tractor Talk > Brand Specific Forums > Other Brands Forum (TYM Tractors, Cub Cadet, Craftsman, Simplicity etc.)

Other Brands Forum (TYM Tractors, Cub Cadet, Craftsman, Simplicity etc.) TYM, Tractors, Cub Cadet, Century, Craftsman, Simplicity etc.... With enough activity, any brand can become a forum. Show the activity here.

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-20-2009, 11:07 AM
A_Acres A_Acres is offline
Junior Member
 
Join Date: May 2009
Location: Ohio
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
A_Acres is on a distinguished road
Default TYM 233 Problem

We recently purchased a TYM 233 and when ut arrived (with about 3 hours on it), none of the gages on the dash work. We couldn't gage RPM's, see how much fuel we had etc etc

Long story short, it was supposedly a bad dash and a mechanic was sent to fix it; rather than replace the dash, he said it was a fuse problem and replaced that. When we got home, NOTHING worked still! We tried to trouble shoot via phone and everytime we put in a new fuse, they would pop.

Now, the hour ticker is also not working. The tractor is back at the dealer to be fixed and we are PRAYING it comes back corrected for good.

Has anyone else experienced this kind of issue with a TYM?
Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





All times are GMT -5. The time now is 04:42 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2002 - 2018, www.DotHQ.com