Net Tractor Talk
       

Go Back   Net Tractor Talk > Brand Specific Forums > Kubota RTV Owners Group Forum

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-10-2020, 11:31 AM
geohorn geohorn is offline
Site Supporter
 
Join Date: Apr 2019
Location: Tx Hill Country
Posts: 123
Thanks: 3
Thanked 125 Times in 73 Posts
geohorn is on a distinguished road
Default Every day ...I check...

Every day I check these forums hoping to pick up some solution to some previously-unknown problem with my X900... but...once-agin... disappointment.... No new posts informing me of someone’s difficulty with their RTV whose knowledge and/or discovery I might some-day find useful for my own if/when it ever displays similar symptoms.

“Dang!”, I think.

Then...it hits me. This is GOOD NEWS!

Doh!

(Really enjoy using my little RTV-X900 around the ranch. Just passed 1000 miles on this 2014 model.).

Coming up on the 400 hr service, when I’ll change all the filters and fluids.
Reply With Quote
The Following 4 Users Say Thank You to geohorn For This Useful Post:
aurthuritis (03-10-2020), beagle hunter (03-10-2020), Doc  (03-10-2020), Jim Slagle  (03-10-2020)
  #2  
Old 03-10-2020, 12:38 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 1,843
Thanks: 373
Thanked 1,344 Times in 818 Posts
aurthuritis is on a distinguished road
Default

yeah the darn things are just uncommonly dependable. and besides most of the "broke down" threads are just result of neglect. usually
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
The Following 2 Users Say Thank You to aurthuritis For This Useful Post:
beagle hunter (03-10-2020), Doc  (03-10-2020)
  #3  
Old 03-10-2020, 02:13 PM
bordercollie's Avatar
bordercollie bordercollie is offline
Senior Member
 
Join Date: Apr 2007
Location: central Mississippi
Posts: 4,513
Thanks: 1,881
Thanked 1,709 Times in 927 Posts
bordercollie is on a distinguished road
Default

Yea, if I didn't have my 4,000 hr rule , I would still have my 2011 900. I actually went over the rule a couple of hundred hours on each of them. With good maintenance they just keep going and going. I would advise checking under the attached rubber floor mat though- could get really scary there since it holds moisture and then some. collie
Reply With Quote
The Following 4 Users Say Thank You to bordercollie For This Useful Post:
aurthuritis (03-10-2020), beagle hunter (03-10-2020), Doc  (03-10-2020), Jim Slagle  (03-10-2020)
  #4  
Old 03-10-2020, 08:56 PM
aurthuritis aurthuritis is offline
Senior Member
 
Join Date: Dec 2014
Posts: 1,843
Thanks: 373
Thanked 1,344 Times in 818 Posts
aurthuritis is on a distinguished road
Default

the first rtv i ever saw was when a seismic crew moved into my area for a study. they had at least a hundred of the old 900 model and a full service crew to keep them running. the ones i got close to had over 10,000 hours on them and they were still going strong. when they left my area the company loaded them all up on big trucks and shipped them to alaska to do another study.
__________________
2014 RTV X1100 CRLA 2014 MX 5100f 2008 RTV 1100cw
Reply With Quote
The Following 4 Users Say Thank You to aurthuritis For This Useful Post:
beagle hunter (03-11-2020), bordercollie (03-11-2020), Doc  (03-11-2020), v10rick (03-14-2020)
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





All times are GMT -5. The time now is 08:03 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright 2002 - 2019, www.DotHQ.com