Net Tractor Talk
       

Go Back   Net Tractor Talk > Other Equipment Forums > Tractor Implements, Add Ons & Accessories Forum

Tractor Implements, Add Ons & Accessories Forum From tilt meters to Box Blades if it goes on a tractor talk about it here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-30-2013, 12:54 PM
Justus14 Justus14 is offline
Junior Member
 
Join Date: Dec 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Justus14 is on a distinguished road
Default Liberty chipper clogging

I bought an 8 Pro series PTO Chipper from Liberty implements http://www.libertychippers.com/, they also make backhoes, tillers and mowers. From the day I received it Ive had problems with the unit clogging up. I have to shut down and clear it twice for every hour of operation. The blades are sharp, belts aligned and in good shape, running at 540 RPM on my B3200 Kubota. Chipping mostly 1 3 green hardwood, occasionally larger pine; do not see any pattern to what I feed it and when it clogs. Liberty thought it was a bad fitting discharge chute so they sent me a new one, fits as badly as the last one so I duct taped up the gap and it still clogs. Now Liberty is totally unresponsive. I think the unit has a design flaw or its just cheap Chinese junk. Has anyone had a similar problem or found any solutions?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





All times are GMT -5. The time now is 12:10 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2002 - 2018, www.DotHQ.com