Net Tractor Talk
       

Go Back   Net Tractor Talk > Brand Specific Forums > Kubota RTV Owners Group Forum

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-05-2019, 04:22 PM
hondajoe hondajoe is offline
Member
 
Join Date: Aug 2016
Posts: 70
Thanks: 1
Thanked 31 Times in 21 Posts
hondajoe is on a distinguished road
Default x900 exhaust broke

Has anyone modified the stock ex to keep it from breaking again.JOE
Reply With Quote
  #2  
Old 08-06-2019, 03:57 AM
dan900 dan900 is offline
Junior Member
 
Join Date: Oct 2014
Location: Southern Illinois
Posts: 24
Thanks: 3
Thanked 11 Times in 5 Posts
dan900 is on a distinguished road
Default

Do a search for "x900 exhaust". There have been others with the broken exhaust--mine included. I was able to get mine replaced under warranty at about 600 hours, but some have welded theirs. Next time I'll be welding.
__________________
Dan
2014 RTV-X900
Reply With Quote
The Following User Says Thank You to dan900 For This Useful Post:
bordercollie (08-06-2019)
  #3  
Old 08-06-2019, 12:32 PM
bordercollie's Avatar
bordercollie bordercollie is offline
Senior Member
 
Join Date: Apr 2007
Location: central Mississippi
Posts: 4,407
Thanks: 1,719
Thanked 1,513 Times in 836 Posts
bordercollie is on a distinguished road
Default

If it broke on the manifold bolt areas then it may have been torqued improperly at the factory. I read that even torquing was very important or else cracking could happen. I'd definitely check to see if something was recalled or defective. Good Luck Joe. collie
Reply With Quote
  #4  
Old 10-12-2019, 01:55 PM
BiffNH BiffNH is online now
Senior Member
 
Join Date: Dec 2014
Location: Squam Lake, New Hampshire
Posts: 152
Thanks: 41
Thanked 52 Times in 36 Posts
BiffNH is on a distinguished road
Default

Quote:
Originally Posted by dan900 View Post
Do a search for "x900 exhaust". There have been others with the broken exhaust--mine included. I was able to get mine replaced under warranty at about 600 hours, but some have welded theirs. Next time I'll be welding.
My exhaust on X900 broke at about 600 miles as well. I have a post about it here. It took me a while to convince Kubota that it due to the fact that the well to the exhaust manifold was never done and therefore the resulting vibration caused it to break at the bracket on the transmission. The aluminum flange of the transmission broke! They at first insisted that someone had stood on the tail pipe! When they finally realized that the bracket near the muffler was not damage and that the flange at the manifold was floating and not connected in any way to the manifold they took the machine and did a major weld on the transmission and the manifold. I now have 8,500 miles on it and all seems fine.
Reply With Quote
  #5  
Old 10-12-2019, 08:10 PM
10-e-c-dirt 10-e-c-dirt is offline
Member
 
Join Date: Mar 2015
Posts: 60
Thanks: 7
Thanked 16 Times in 12 Posts
10-e-c-dirt is on a distinguished road
Default

My X900 broke at the manifold, I just put a straight out pipe on it , its a little loud, but I never wear my hearing aid anyway, might give it .5 more horse power,Lol
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





All times are GMT -5. The time now is 05:59 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002 - 2019, www.DotHQ.com