Net Tractor Talk
       

Go Back   Net Tractor Talk > Brand Specific Forums > Kubota RTV Owners Group Forum

Reply
 
Thread Tools Search this Thread Display Modes
  #1901  
Old 12-21-2017, 06:23 PM
Doc's Avatar
Doc Doc is offline
Chief Bottle Washer / Admin

 
Join Date: Apr 2007
Location: Ohio USA
Posts: 5,726
Thanks: 1,507
Thanked 377 Times in 233 Posts
Doc is on a distinguished road
Default

Quote:
Originally Posted by Ohio_Pawpaw_Grower View Post
2005 Silverado, about 300K miles. Anyone have trouble with low oil pressure on start up?

I am told its a fairly common problem with gasoline 6.0 liter V8 which doesn't make me feel any better.

Just wondered if anyone else has experienced this and if so, did you fix the issue or replace the engine - which are the options I have right now.

Grateful to know what worked for you.
I don't know the answer but I have exactly the same truck. Ck engine light stays on. Had it checked and it was something that would not impact the operation of the engine. O2 sensor.
So please share when you do learn anything on this.
__________________
Scott me up Beamy!

Other Fun Forums:
Forums Forums .com +++ Net Pet Talk Forums +++ Net Cooking Talk Forums +++
Reply With Quote
  #1902  
Old 12-21-2017, 06:29 PM
avantiguy avantiguy is offline
Senior Member
 
Join Date: Feb 2014
Location: michigan
Posts: 261
Thanks: 20
Thanked 114 Times in 81 Posts
avantiguy is on a distinguished road
Default

Quote:
Originally Posted by Ohio_Pawpaw_Grower View Post
2005 Silverado, about 300K miles. Anyone have trouble with low oil pressure on start up?

I am told its a fairly common problem with gasoline 6.0 liter V8 which doesn't make me feel any better.

Just wondered if anyone else has experienced this and if so, did you fix the issue or replace the engine - which are the options I have right now.

Grateful to know what worked for you.
Is it low pressure at startup or at all temps. On a high mileage engine the oil pressure drops do to clearances opening up such as bearings, lifter galleries and the oil pump itself, as I'm sure you are aware.

If it's only low at startup, I'd check the pressure with a separate gauge as I might suspect the oil pressure sender may becoming defective.

If it's at all temperatures, a rebuilt long block is probably the best value as SBC's even the newer LS's are pretty reasonable from Jasper and the other usual suspects.
Reply With Quote
  #1903  
Old 12-21-2017, 07:44 PM
shinnery shinnery is offline
Senior Member
 
Join Date: Jan 2015
Location: Hawley, Texas
Posts: 162
Thanks: 33
Thanked 57 Times in 40 Posts
shinnery is on a distinguished road
Default

I don't own no chebbys but if I was having low oil pressure problems I believe my first step would be to check the gauge and then look at replacing the oil pump.
Bryce
Reply With Quote
  #1904  
Old 12-21-2017, 08:04 PM
bordercollie's Avatar
bordercollie bordercollie is offline
Senior Member
 
Join Date: Apr 2007
Location: central Mississippi
Posts: 3,899
Thanks: 1,053
Thanked 710 Times in 458 Posts
bordercollie is on a distinguished road
Default

Quote:
Originally Posted by thcri View Post
'



Butane or LP? Not that they don't exist (just never heard of one) but we had a lot of LP tractors around here. I think I even have a picture of a 4020.
My bil calls it butane but yes, it is really LP . I guess we will always refer to it as "the butane tractor" . The cut off mechanisms (liquid and vapor ,)for the fuel tank are a bear to find. He did find 2 original kits on e bay though .Otherwise it leaks terribly. bordercollie
Reply With Quote
The Following User Says Thank You to bordercollie For This Useful Post:
thcri (12-28-2017)
  #1905  
Old 12-27-2017, 03:02 PM
Doc's Avatar
Doc Doc is offline
Chief Bottle Washer / Admin

 
Join Date: Apr 2007
Location: Ohio USA
Posts: 5,726
Thanks: 1,507
Thanked 377 Times in 233 Posts
Doc is on a distinguished road
Default

Yesterday I hauled my RTV1140 to the dealer for it's 800 hour full service. Fingers crossed they can also get the windshield to work with the RTV900 top I put on the 1140. Afraid they will tell me I have to go with the roof made for the RTV-1140 for the windshield to fit right. That roof is expensive. They were doing the work today, no call yet. Hope that is a good sign.
__________________
Scott me up Beamy!

Other Fun Forums:
Forums Forums .com +++ Net Pet Talk Forums +++ Net Cooking Talk Forums +++
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





All times are GMT -5. The time now is 10:56 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2002 - 2018, www.DotHQ.com