Net Tractor Talk
       

Go Back   Net Tractor Talk > Brand Specific Forums > Kubota RTV Owners Group Forum

Reply
 
Thread Tools Search this Thread Display Modes
  #21  
Old 11-13-2017, 06:54 AM
D&D Farm's Avatar
D&D Farm D&D Farm is offline
Senior Member
 
Join Date: Apr 2007
Location: On top of MY mountain in Sugar Valley, Georgia
Posts: 1,147
Thanks: 506
Thanked 454 Times in 290 Posts
D&D Farm is an unknown quantity at this point
Default

Quote:
Originally Posted by muffler man View Post
leave it installed
That's exactly what I figured to do now for 600 hours since I replaced the pump with an electric one that is still just pumpin away. NO PROBLEMS or erratic running. I did place the little rubber stoppers over the input and output of the original pump that came with the replacement pump to keep dust and such out...................
__________________
Sugar Valley, Georgia
Sittin back enjoying life with my grand babies, Mules, wife of course and just PEACE........
God has given me all of this and I surely do appreciate HIM for that and more.
Reply With Quote
The Following User Says Thank You to D&D Farm For This Useful Post:
bordercollie (11-13-2017)
  #22  
Old 02-19-2018, 04:41 PM
bbonds007 bbonds007 is offline
Junior Member
 
Join Date: Feb 2018
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
bbonds007 is on a distinguished road
Default

I just diagnosed my 2004 RTV900 with bad fuel pump as well. I already have a new mechanical pump ordered.
I had a spare electric pump and threw it on there to test; it fired and ran fine. I can't tell much difference power or rpm-wise, it might have had a little more pep. It has been several months since I drove it last.
Mine doesn't spin wheels or have much low end pull though....it has more of a sluggish start. I am looking any adjustments for that. Any tips there? I also have that kit ordered to mod it to the 1100 valve after hearing of the improved performance with it.
Where exactly did you wire your electric pump to? If I do find after installing the new mechanical that the electric has more power, I might just do a permanent change to electric.

Last edited by bbonds007; 02-19-2018 at 04:54 PM.
Reply With Quote
  #23  
Old 02-19-2018, 05:24 PM
D&D Farm's Avatar
D&D Farm D&D Farm is offline
Senior Member
 
Join Date: Apr 2007
Location: On top of MY mountain in Sugar Valley, Georgia
Posts: 1,147
Thanks: 506
Thanked 454 Times in 290 Posts
D&D Farm is an unknown quantity at this point
Default

There is a "spare" connection there by the neutral safety wiring and device. The polarity is wrong on the plug; but all one has to do is go in and move the wires around in the plug. The pump I got off of Amazon had the same plug but wrong polarity so that was the cause for the change................Good luck
__________________
Sugar Valley, Georgia
Sittin back enjoying life with my grand babies, Mules, wife of course and just PEACE........
God has given me all of this and I surely do appreciate HIM for that and more.
Reply With Quote
The Following 2 Users Say Thank You to D&D Farm For This Useful Post:
bbonds007 (02-21-2018), Doc  (02-19-2018)
  #24  
Old 04-10-2018, 08:53 PM
ShortFatBaldGuy ShortFatBaldGuy is offline
Junior Member
 
Join Date: Apr 2018
Posts: 9
Thanks: 0
Thanked 8 Times in 2 Posts
ShortFatBaldGuy is on a distinguished road
Default

Hi Folks, I have a similar problem. I bought a 2008 RTV 1100 a couple weeks ago and it turned out to have a lot of problems. I replaced the starter and starter relay fuse and got the starter working again. Then I replaced a rear hub to get 2WD working again. Now it won't fire up. Turns out it had a bunch of water in the fuel. It was so bad that when I siphoned it out, there was a one inch layer of ice on the bottom of the tank. I cleaned that all up and replaced the fuel filter but it still won't fire up. I just removed the line from the outlet of the fuel pump and I'm getting nothing coming out. Since I emptied all the lines, is there some sort of priming procedure required? Could the water in the fuel have ruined the pump. I've cranked it for several minutes. Do I need to crank it longer. I don't want to abuse a brand new starter. I see in this thread that an electric fuel pump might be a good idea. Should I try that next? I know that all this trouble-shooting is getting me real familiar with the RTV and that's a good thing but it would be nice to spend some time riding in it. Any help would be greatly appreciated. God bless!
Reply With Quote
  #25  
Old 04-14-2018, 04:52 PM
ShortFatBaldGuy ShortFatBaldGuy is offline
Junior Member
 
Join Date: Apr 2018
Posts: 9
Thanks: 0
Thanked 8 Times in 2 Posts
ShortFatBaldGuy is on a distinguished road
Unhappy Fixed!

I put the electric pump on that D&D suggested and it's running strong again. We got about 3" of rain in Michigan today so me and kids ran around the yard tearing it up. It was nice to finally get to play with it. We got it stuck in 2WD so I put it in 4WD and the front wheels did not spin so I guess I'll be looking at that next...
Reply With Quote
The Following User Says Thank You to ShortFatBaldGuy For This Useful Post:
D&D Farm (04-14-2018)
  #26  
Old 04-14-2018, 05:48 PM
D&D Farm's Avatar
D&D Farm D&D Farm is offline
Senior Member
 
Join Date: Apr 2007
Location: On top of MY mountain in Sugar Valley, Georgia
Posts: 1,147
Thanks: 506
Thanked 454 Times in 290 Posts
D&D Farm is an unknown quantity at this point
Default

Sorry I didn't see your posts and REALLY GLAD that YOU are moving and having fun WITH THOSE KIDS.....God is great HUH???....Dennis
__________________
Sugar Valley, Georgia
Sittin back enjoying life with my grand babies, Mules, wife of course and just PEACE........
God has given me all of this and I surely do appreciate HIM for that and more.
Reply With Quote
  #27  
Old 04-14-2018, 05:52 PM
ShortFatBaldGuy ShortFatBaldGuy is offline
Junior Member
 
Join Date: Apr 2018
Posts: 9
Thanks: 0
Thanked 8 Times in 2 Posts
ShortFatBaldGuy is on a distinguished road
Default

Yes, God is Great! When she fired up and ran strong, I looked upward and said "Thank you Lord!"
Reply With Quote
Reply

Tags
fuel pump

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump





All times are GMT -5. The time now is 03:57 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright 2002 - 2018, www.DotHQ.com