Jensen HD radio losing preset memory

BiffNH

Super Site Supporter
SUPER Site Supporter
I have the factory Jensen HD radio and the problem I have is that it quite frequently clears all the stations I have programmed in. It does not lose the time, nor is there a problem with loose connections. It happens after about 7 starts when the radio is left on. There is no interruption in reception while it is on and it behaves fine except the once in a while when the memory is cleared of all stations! Anyone have the same problem?
 

avantiguy

Super Site Supporter
SUPER Site Supporter
Considering a lot of inexpensive radios need a fulltime power source to remember presets, is it possible that you have a loose or corroded wire from the battery as they are acting just like they only have a power source when the ignition is on.
 

Tsunamibob

Member
Considering a lot of inexpensive radios need a fulltime power source to remember presets, is it possible that you have a loose or corroded wire from the battery as they are acting just like they only have a power source when the ignition is on.
Or the loss of power when the starter is engaged causes it to lose the memory
 

BiffNH

Super Site Supporter
SUPER Site Supporter
The lighted dial never fades and the clock has never had to be reset. The lighted dial shows no dimming when the starter is engaged. In fact this has only happened when the engine is warm and previously run. Never when starting in cold and when the glow plug has needed to be used and the temperature is below freezing. The memory for the station presets and the clock and dial light is on dedicated 5 amp circuit that is always on when the key is on. All the connections are tight and secure.
 

Ohio_Pawpaw_Grower

Member
Site Supporter
Those presets are maintained either by an internal battery in the radio or your 12V supply. Assuming no internal components have broken down, first possibility I think of is the internal battery has died. You would have to crack the case and look for a round type battery, like a CR2032. Does your clock reset if you disconnect from power?
 

BiffNH

Super Site Supporter
SUPER Site Supporter
I just took delivery of the new machine in December and have not had the radio out. I have not disconnected the power. I'll pull the 5 amp fuse. That is a good idea. The interesting thing is it is somewhat sporadic - and never happens when the radio is off when I start the machine up - only if the radio is on when I turn it off. I have not been able to duplicate the "problem" with any sense of a pattern other than something like 7 events - but even this is just speculation since I can't seem to duplicate it. I appreciate your ideas and help.
 

aurthuritis

Site Supporter
Site Supporter
you didn't let the majik blue smoke escape the radio did you? once it escapes it's impossible to put it back in.
 

bordercollie

Gold Site Supporter
Gold Site Supporter
I think it's that internal battery like Ohio Pawpaw mentioned. If the battery is weak/dead, it does seem like it would act up if the radio was left on when the key was turned off. I'm sure not an electrician though so my opinion on this isn't worth much.
 

Alaskanassasin

Senior Member
Site Supporter
Good deal @BiffNH i have a feeling it’s something to do with the bota though. It has done that since i bought mine. I think I set the presets like twice then realized it was erasing them and never used the damn thing again, besides that it’s hard to see up there
 
Top