Ad here

Fuel flow issue RTV1100 '09


New member
We bought the diesel RTV at an auction (had been stored in a dry garage) and ran it without any issues for a year, then it sat for 5 months due as we waited to fix a broken front shock and axle, no thanks to a grandkid. It has about 500 hours.

After the repair, it started fine and ran for about 30 minutes. We parked it, then the next time we cranked it, it would not fire or even sputter. I replaced the fuel stop solenoid, got it started and it ran like it was un-governed at high rpms with lots of black smoke. Pulling back on the throttle cable had no effect so I shut it off by squeezing the fuel line. Here is the sequence of what I did, leading up to then:

1. The tank had been about 1/3 full. I filled it using a really fine diesel filter as I always do.
2. Replaced the fuel filter.
3. Checked for fuel flow post-filter. It was good.
4. Checked voltage to the fuel stop solenoid and got 12 volts on both wires.
5. Tried to remove the fuel lift pump to see if there was anything obviously wrong. Since it didn't want to come all the way out, I tightened it back up.
6. Opened the injector connections to bleed air. I never was able to see fuel get pumped out.
7. Ordered and installed a Chinese fuel stop solenoid for $35 compared to upwards of $130 for the Kubota OEM part. We don't have unlimited funds.s
8. Started the engine and that's when all h@#$ broke loose, no throttle control, had to squeeze fuel line to shut it off.
9. When unplugging the solenoid the whole cover came off and I realized that it had fried itself.

We do not have any reputable Kubota dealers nearby. The guy who fixed the suspension took months to work on it. So, I would appreciate advice!

I don't want to assume anything at this point. Bad fuel, clogged fuel filter, or an air pocket could have been the original issue. I could put the factory solenoid back in, but at this point I am gun-shy. I don't think there is any reason to suspect the injector pump, but please correct me if I am wrong. If running the engine briefly at high rpms could have damaged it, maybe now is the time to take it to a dealer. Should I just re-install the solenoid and give it a try? Thanks in advance!


Staff member
Gold Site Supporter
Good post with lots of information.
A couple of questions. What led you to think it was the fuel stop solenoid? Does the original solenoid appear to be fried also?


New member
I'm not having the same issues on my RT900XT Motor got hot and had to replace the head and fuel injectors plus the water pump and some other bits. This had plenty of power before it has gotten hot and all the repairs. It has seemed to have less power and struggles and start giving me black smoke at throttle and nothing during idle. You can floor the pedal and it gets up to speed but struggle during driving.

I check to see if this has a fuel mixture supply on the side but could not find one on this 3-injector pump.
Just not sure where to head at this point any help would be great


New member
try adjusting the valves and check the compression. also check that the new injectors are the correct part.
These are all at factory spec and torque setting. The injectors are factory along with the rebuilt head. The only thing I can think is the fuel pump


New member
Good post with lots of information.
A couple of questions. What led you to think it was the fuel stop solenoid? Does the original solenoid appear to be fried also?
Thanks Doc, life's busy and I am just now getting back to you from last week's post.

On the reason for thinking it was the solenoid, I figured that the lack of fuel flow was either the lift pump or solenoid. Since I failed to get the lift pump out, as far as I could tell I had all the air out and the fuel line clamps all seemed tight, short of pulling out the injector pump I figured I could do the easy replacement of the solenoid.

There's another post that came in after yours, suggesting that I check a spring that's below the injector pump. Will check that one out before trying again.

No, the original solenoid does not appear to be fried. Before seeing your post, I reinstalled it and tried to start the engine. This time the starter didn't crank, so now I have a new problem. Do you think it makes sense to check the voltage to the starter solenoid?

One more question: Before the runaway engine start in my post, I primed the lift pump several times. Is it possible that I pumped too much fuel, causing the runaway situation?